Neuigkeiten

Trotz Hausumbau beim einen oder beruflicher Vollauslastung beim anderen geht es auch hier weiter mit Fehlerbehebung oder Umsetzung von Verbesserungsvorschlägen.

Abgesehen von kleineren Änderungen, Fehlerbehebungen und Updates sind die folgenden Punkte für jeden Besucher sichtbar:

Melderkarte

Auf Anregung von Melder Brico66 werden bei einem Klick auf einen Melder in der Melderkarte ein oder mehrere (je nach Anzahl der Pedelecs eines Melders) Links zum Steckbrief des Pedelecs angezeigt. Es wäre natürlich einfach gewesen die Links manuell einzutragen, aber eine automatische Lösung ist immer besser, daher hat das etwas länger gedauert.

Ich prüfe noch, ob ich diese Links z.B. auch bei den Diagrammen einbauen kann. Mal sehen…

Das Plugin für die Melderkarte wurde auch aktualisiert, funktioniert allgemein besser und hat auch noch ein paar andere nette Features, die es z.B. einfacher machen die Marker zu verwalten.

Daten

Teilweise wurden Daten falsch ausgegeben, wenn ein Melder mehr als ein Pedelec hat und die Pedelecs den gleichen Motor haben, z.B. hier. Danke an Scholty für den Hinweis!

Die Pedelecs eines Melders werden jetzt getrennt angezeigt (in Abhängigkeit von den weiteren Kriterien wie Kilometerstand usw.). Damit stimmen jetzt die ausgegebenen Kilometer und der Zeitraum wieder.

Ausserdem werden keine Daten mehr angezeigt, bei denen die errechnete durchschnittliche monatliche Kilometerleistung höher als 1.600km ist. Wenn z.B. ein Melderprofil kein Kaufdatum enthält und nur eine oder wenige Meldungen gespeichert sind, die dann auch nur einen kurzen Zeitraum umfassen, wurden hier extrem hohe Werte ausgegeben. Monatliche Kilometerleistungen von 2.000km und mehr sind dann doch eher unwahrscheinlich. Die durchschnittliche monatliche Kilometerleistung über alle Meldungen in der Datenbank liegt derzeit bei ~1.600km.

18 Kommentare

  1. Hallo Thorsten,

    toller Job und Respekt, dass ihr zwei so viel (Frei-)Zeit investiert! Leider schleichen sich mit Verbesserungen auch wieder neue Fehler ein – ich kenne das leider nur zu gut aus meinem eigenen Alltag. Jetzt ist folgendes passiert: Sobald ich angemeldet bin und auf einen beliebigen Menüpunkt klicke (habe nicht alle, aber einige ausprobiert) bin ich sofort wieder abgemeldet bzw. meine Session weg. Ich wollte eure neueste Auswertung anschauen – geht damit leider nicht 🙁

    1. Hi, hmm, da gestern oder vorgestern Kilometermeldungen eingetrudelt sind, ist das ein individuelles Problem. Ich vermute, das hängt damit zusammen dass ich am Wochenende ein Plugin aktiviert habe, das einen Seitencache erstellt damit die Ladezeiten verringert werden. Offensichtlich führt das z.B. in der Konstellation mit deinen Browsereinstellungen zum geschilderten Verhalten. Frage: hast Du Cookies komplett ausgeschaltet? Wenn ja, kannst Du bitte mal eine Ausnahme für pedelecmonitor.com eintragen und schauen, ob das Problem dann immer noch auftritt?

      1. Hallo Thorsten,

        ich habe meine Cookies temporär wieder aktiviert, jetzt geht es – fast.
        Zwei Probleme sehe ich noch:
        Erstens: wenn ich nach der Anmeldung im Menü hin- und herklicke, bleibe ich generell angemeldet, aber mit einer Ausnahme: beim Klick auf “Start” haut es mich wie vorher wieder raus.
        Zweite Sache: ich wollte das neue Featur in der Melderkarte ausprobieren und habe mir das für 4 Profile angeschaut: mein eigenes und drei beliebige andere. Ergebnis: bei mir und einem weiteren Mitglied kommt ein http-404er Statuscode, bei einem Profil steht als Menüeintrag “keine Daten verfügbar” oder so ähnlich und beim letzten Kandidaten kommt erst eine Meldungsbox mit einer Meldung “No components found” (oder so ähnlich), im Anschluss wird aber trotzdem die Profilseite angezeigt, hier geht es also prinzipiell.
        VG,
        Thomas

  2. Hi,

    jetzt ist irgendwie gefühlt alles hinüber:
    Vorhin habe ich 20 Anläufe gebraucht um meinen KM-Stand eingeben zu können…Nach der Anmeldung ist vor der Anmeldung: Nach der Anmeldung wurde ich auf mein Profil geleitet, im Menü stand aber wieder anmelden usw. Irgendwann habe ich im Profil auf Kommentare geklickt, danach wechselte das Menü auf “Melder” und ich konnte einmalig meine KM für Mai eingeben. War aber wie gesagt nur einmal, ich habe es jetzt noch mehrfach versucht, keine Chance mich anzumelden. Cookies sind aktiv, Browserverlauf wird auch nicht gelöscht. Das Menü “Daten” mit den Vergleichsstatistiken geht praktisch gar nicht mehr. Mal werden bei mir die korrekten 28.837 km, mal aber auch nur gut 8000 angezeigt. Man kann beim Hersteller keine Motoren mehr auswählen, mein Pedelec erscheint mal in meinem Profil, manchmal aber auch nicht. Ganz ehrlich: macht so keinen Spaß.
    Traurige Grüße,
    Thomas

    1. Hi, kein Grund zur Traurigkeit. Ich habe jetzt das Cache-Plugin deaktiviert, d.h. die Seite hat wieder den selben Zustand wie vor dem letzten Wochenende.
      Es ist aber definitiv irgendwas im Zusammenspiel deines Browsers (oder irgend ein anderes Stück Software wie z.B. Werbeblocker/Firewall etc.) und dem Caching, was hier zu Problemen führt. Aber das wird sich noch finden…

  3. Hallo LesPaul,

    bei mir stimmt irgendwas nicht.

    – Ich kann keine Kilometer melden

    – Mein Profil Daten werden nicht übernommen
    vielleicht habe ich ja auch etwas falsch eingegeben beim
    Fahrrad Model

    – Meine runtergeladenen Daten sind irgendwie strubelig
    oder werden bei mir nur falsch angezeigt. Es fehlt in manchen Eingaben
    die Mail Adresse.

    könnt ihr mir helfen , ich würde gerne weiter machen. Kann ich aber leider nicht

    Viele Grüße
    Andreas (Ace Frealy)

  4. Hallo LesPaul,

    ein Teil funktioniert jetzt schon,
    meine Pedelec Daten sind jetzt unter
    Daten – Melder zu sehen. Da steht bei mir der Name ” Ace Frealy”

    Bei der Eingabe der Kilometer steht da unter Melder der Name “ace-frealy”
    und ich kann kein Pedelec auswählen obwohl ich ein auf Active gestellt habe.
    Kann das an den verschieden Namen liegen ?
    Ich habe folgende Schreibweisen auf der Webseite gesehen.

    Ace Frealy
    ace-frealy
    Ace-Frealy

    Ich kann keine Kilometer eingeben und ich kann meine Daten nicht runterladen

    Kannst du bitte nochmal nachsehen

    Danke
    Andreas

  5. Hallo LesPaul,

    danke für deine Arbeit.
    Ich habe gerade meine 10.000 Km gemeldet
    jetzt bin ich aber wieder 2x in der Liste
    “Melder und Pedelec” vertreten
    1x als “ace-frealy” mit 10.000 km ohne Steckbrief Daten.
    und
    1x als “Ace Frealy” mit 9.590 km mit Steckbrief Daten.

    Es liegt bestimmt am Bindestrich und evtl. der Groß und Klein Schreibung

    Als ihr die Daten damals aus dem alten System übernommen habt
    da war ich schon mit den beiden Schreibweisen vertreten.

    Ich konnte zwar gerade wieder mein Bike auswählen beim
    Kilometer Melden, aber er hat wieder einen zweiten Ace Frealy angelegt.
    Das hat die Datenbank schon mal gemacht, als alles noch ganz neu war.

    Habt ihr keine Chance das zu reparieren ??? Und überall nur einen Namen einzutragen.
    Mir ist egal ob “ace-frealy” oder “Ace Frealy”

    Gruß
    Andreas

    1. Guten Morgen,

      ich habe die Daten jetzt erstmal berichtigt.
      Bei der nächsten Anmeldung bitte mit “Ace Frealy” ohne Bindestrich anmelden!
      Du bist nirgendwo mehr mit “-” hinterlegt, ich habe auch mal die kompletten Userdaten durchgeschaut, da ist nichts mehr.
      Ansonsten, Duisburg-Herne ist jetzt nicht so weit, dann müssen wir uns halt mal zusammensetzen um das auszusortieren. Alternativ, wenn das für dich ok ist, ich ändere für deinen Account das Passwort ab und melde mich dann als “Ace Frealy” an. Dann kann ich mir das auch mal direkt anschauen.
      Bei einer Passwortänderung durch Admins werden User automatisch informiert, wenn ich dann damit durch bin kannst Du ja über “Passwort vergessen” ein neues setzen.

      Gruß
      Thorsten

  6. Hallo LesPaul,

    danke das du dir immer die Arbeit machst, aber es hat leider immer noch nicht funktioniert
    Unter Eingabe Kilometerstand ist noch ein “ace-frealy”.
    Jetzt bin ich leider wieder zwei mal in der Melder Liste
    Melde dich ruhig als Admin bei meinem Account an.

    Der Rhein-Herne Kanal ist eine schöne Verbindung zwischen den beiden Städten, in der Mitte
    gibt es bestimmt schöne Biergärten wo man das aussortieren kann.

    Gruß
    Andreas

    1. Hi, Du hast eine Mail bekommen, funktioniert jetzt alles.
      Irgendwann die nächsten 4 Wochen habe ich noch eine Tour zur Halde Hoheward geplant, vielleicht sieht man sich da ja.

  7. Hallo Les Paul,
    danke das du mir geholfen hast. Ich wohne nur ca. 12 km von der Halde entfernt und war schon länger nicht mehr da. Wenn du willst , dann sag einfach bescheid.

    Gruß
    Andreas

Kommentar hinterlassen

Deine E-Mail-Adresse wird nicht veröffentlicht. Erforderliche Felder sind mit * markiert.